aboutsummaryrefslogtreecommitdiffstats
path: root/net-misc/gandi-cli/gandi-cli-1.5.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-01-13 15:59:49 +0100
committerWynn Wolf Arbor2020-01-13 15:59:49 +0100
commit90b60b5044587535e792ed5410acbf10a76963e7 (patch)
tree316d681581cb2b3a4218f31e72cab376e70b8252 /net-misc/gandi-cli/gandi-cli-1.5.ebuild
downloadpramantha-90b60b5044587535e792ed5410acbf10a76963e7.tar.gz
Initial import
Diffstat (limited to 'net-misc/gandi-cli/gandi-cli-1.5.ebuild')
-rw-r--r--net-misc/gandi-cli/gandi-cli-1.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/gandi-cli/gandi-cli-1.5.ebuild b/net-misc/gandi-cli/gandi-cli-1.5.ebuild
new file mode 100644
index 0000000..3cb71e1
--- /dev/null
+++ b/net-misc/gandi-cli/gandi-cli-1.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} pypy )
+
+inherit distutils-r1
+
+MY_PN="${PN//-/.}"
+DESCRIPTION="CLI to easily create and manage web resources for your Gandi account."
+HOMEPAGE="https://github.com/Gandi/gandi.cli"
+SRC_URI="https://github.com/Gandi/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/click-7
+ dev-python/requests
+ dev-python/pyyaml
+ dev-python/ipy
+ dev-python/namespace-gandi
+"
+
+DEPEND="dev-python/namespace-gandi"
+
+RESTRICT="mirror"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}