aboutsummaryrefslogtreecommitdiffstats
path: root/net-irc/quarg/quarg-0.2.0.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2023-03-30 22:22:06 +0200
committerWolfgang Müller2023-03-30 22:22:06 +0200
commitb473fdca2c319ae4a765d50e05275b185778e1b4 (patch)
tree99ccc415ab9a3109ccc82e11254d6dc14c750b28 /net-irc/quarg/quarg-0.2.0.ebuild
parente25fef8bdefab506a09e77100d9a4b4490a6a85b (diff)
downloadpramantha-b473fdca2c319ae4a765d50e05275b185778e1b4.tar.gz
net-irc/quarg: add 0.2.0, drop 0.1.3
Diffstat (limited to 'net-irc/quarg/quarg-0.2.0.ebuild')
-rw-r--r--net-irc/quarg/quarg-0.2.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-irc/quarg/quarg-0.2.0.ebuild b/net-irc/quarg/quarg-0.2.0.ebuild
new file mode 100644
index 0000000..0657929
--- /dev/null
+++ b/net-irc/quarg/quarg-0.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{10,11} )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1
+
+DESCRIPTION="Search Quassel logs for matching messages and print them"
+HOMEPAGE="https://git.oriole.systems/quarg"
+
+SRC_URI="https://git.oriole.systems/quarg/snapshot/${P}.tar.gz"
+KEYWORDS="amd64 x86"
+
+RESTRICT="mirror test"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="sqlite postgres"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ postgres? ( dev-python/psycopg[${PYTHON_USEDEP}] )
+ >=dev-python/sqlalchemy-2.0[${PYTHON_USEDEP},sqlite?]
+"
+
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ default
+
+ doman quarg.1
+}