aboutsummaryrefslogtreecommitdiffstats
path: root/net-irc/quarg/quarg-0.1.1.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2021-05-06 16:34:58 +0200
committerWolfgang Müller2021-05-06 16:34:58 +0200
commit20ebdba090637f4a86e47ae971e9846a456f5793 (patch)
treef14968a4e186e0059bc178584f466c23bde49932 /net-irc/quarg/quarg-0.1.1.ebuild
parent3225549ec511b89c6b4dcddc526e2ff4c25d5a5c (diff)
downloadpramantha-20ebdba090637f4a86e47ae971e9846a456f5793.tar.gz
net-irc/quarg: Add 0.1.1
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Wolfgang Müller <wolf@oriole.systems>
Diffstat (limited to 'net-irc/quarg/quarg-0.1.1.ebuild')
-rw-r--r--net-irc/quarg/quarg-0.1.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-irc/quarg/quarg-0.1.1.ebuild b/net-irc/quarg/quarg-0.1.1.ebuild
new file mode 100644
index 0000000..efb5865
--- /dev/null
+++ b/net-irc/quarg/quarg-0.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Search Quassel logs for matching messages and print them"
+HOMEPAGE="https://git.oriole.systems/quarg"
+
+SRC_URI="https://git.oriole.systems/quarg/snapshot/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+RESTRICT="mirror test"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="sqlite postgres"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
+ >=dev-python/sqlalchemy-1.4[${PYTHON_USEDEP},sqlite?]
+"
+
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ default
+
+ doman quarg.1
+}