aboutsummaryrefslogtreecommitdiffstats
path: root/media-sound/mpdevil/mpdevil-1.6.0.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2022-02-24 14:45:07 +0100
committerWolfgang Müller2022-02-24 14:45:07 +0100
commit15eaeecda01f5a24456aaefe819eaaf5d55bd7e1 (patch)
tree94329b278c77d8152eaa9964e48f986b50fb2c87 /media-sound/mpdevil/mpdevil-1.6.0.ebuild
parent6c59d23817b16d952bca678a04ad02458a6cbd9a (diff)
downloadpramantha-15eaeecda01f5a24456aaefe819eaaf5d55bd7e1.tar.gz
media-sound/mpdevil: Bump to 1.6.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Diffstat (limited to 'media-sound/mpdevil/mpdevil-1.6.0.ebuild')
-rw-r--r--media-sound/mpdevil/mpdevil-1.6.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/media-sound/mpdevil/mpdevil-1.6.0.ebuild b/media-sound/mpdevil/mpdevil-1.6.0.ebuild
new file mode 100644
index 0000000..37581ac
--- /dev/null
+++ b/media-sound/mpdevil/mpdevil-1.6.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9,10} )
+inherit python-single-r1 gnome2-utils meson xdg
+
+DESCRIPTION="A simple music browser for MPD"
+HOMEPAGE="https://github.com/SoongNoonien/mpdevil"
+SRC_URI=""
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SoongNoonien/${PN}.git"
+else
+ SRC_URI="https://github.com/SoongNoonien/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="dev-libs/gobject-introspection:=
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-mpd[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ ')
+"
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ gnome2_schemas_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_gconf_uninstall
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}