aboutsummaryrefslogtreecommitdiffstats
path: root/media-fonts/iosevka/iosevka-3.5.0.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-09-10 12:23:13 +0200
committerWynn Wolf Arbor2020-09-10 12:23:13 +0200
commit270d7114736c83842afd4a633e6a261c1d9bf4c1 (patch)
tree31992bbb06136cdd7e616b54a773a70f09db53d8 /media-fonts/iosevka/iosevka-3.5.0.ebuild
parent42c9d3c0eac558486f50289624904edd47256045 (diff)
downloadpramantha-270d7114736c83842afd4a633e6a261c1d9bf4c1.tar.gz
media-fonts/iosevka: Bump to 3.5.0 and drop default USE flags
Most people will want to install only the main font group, so drop any USE flags on variants that were enabled by default. Package-Manager: Portage-3.0.4, Repoman-3.0.1
Diffstat (limited to 'media-fonts/iosevka/iosevka-3.5.0.ebuild')
-rw-r--r--media-fonts/iosevka/iosevka-3.5.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-fonts/iosevka/iosevka-3.5.0.ebuild b/media-fonts/iosevka/iosevka-3.5.0.ebuild
new file mode 100644
index 0000000..11541ea
--- /dev/null
+++ b/media-fonts/iosevka/iosevka-3.5.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit font
+
+DESCRIPTION="Slender typeface for code, from code"
+HOMEPAGE="https://typeof.net/Iosevka/"
+SRC_URI="https://github.com/be5invis/${PN}/releases/download/v${PV}/pkg-iosevka-${PV}.zip
+curly? ( https://github.com/be5invis/${PN}/releases/download/v${PV}/pkg-iosevka-curly-${PV}.zip )
+curly-slab? ( https://github.com/be5invis/${PN}/releases/download/v${PV}/pkg-iosevka-curly-slab-${PV}.zip )
+aile? ( https://github.com/be5invis/${PN}/releases/download/v${PV}/pkg-iosevka-aile-${PV}.zip )
+etoile? ( https://github.com/be5invis/${PN}/releases/download/v${PV}/pkg-iosevka-etoile-${PV}.zip )
+sparkle? ( https://github.com/be5invis/${PN}/releases/download/v${PV}/pkg-iosevka-sparkle-${PV}.zip )"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE="curly curly-slab aile etoile sparkle"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+FONT_S="${S}/ttc"
+FONT_SUFFIX="ttc"