aboutsummaryrefslogtreecommitdiffstats
path: root/app-shells/fzf/fzf-0.24.4.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-12-10 16:33:11 +0100
committerWynn Wolf Arbor2020-12-10 16:33:11 +0100
commit7d5c29ee1926049de503cb863c172846f25e9025 (patch)
tree30624f5fc1118d5232b87078b537281feb5e2102 /app-shells/fzf/fzf-0.24.4.ebuild
parent48f16b99645d08a6375f6b7794e3d028a642cfb6 (diff)
downloadpramantha-7d5c29ee1926049de503cb863c172846f25e9025.tar.gz
app-shells/fzf: Bump to 0.24.4
Package-Manager: Portage-3.0.9, Repoman-3.0.2
Diffstat (limited to 'app-shells/fzf/fzf-0.24.4.ebuild')
-rw-r--r--app-shells/fzf/fzf-0.24.4.ebuild94
1 files changed, 94 insertions, 0 deletions
diff --git a/app-shells/fzf/fzf-0.24.4.ebuild b/app-shells/fzf/fzf-0.24.4.ebuild
new file mode 100644
index 0000000..9b0d006
--- /dev/null
+++ b/app-shells/fzf/fzf-0.24.4.ebuild
@@ -0,0 +1,94 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="A general-purpose command-line fuzzy finder"
+HOMEPAGE="https://github.com/junegunn/fzf"
+
+EGO_SUM=(
+ "github.com/gdamore/encoding v1.0.0"
+ "github.com/gdamore/encoding v1.0.0/go.mod"
+ "github.com/gdamore/tcell v1.4.0"
+ "github.com/gdamore/tcell v1.4.0/go.mod"
+ "github.com/lucasb-eyer/go-colorful v1.0.3"
+ "github.com/lucasb-eyer/go-colorful v1.0.3/go.mod"
+ "github.com/mattn/go-isatty v0.0.12"
+ "github.com/mattn/go-isatty v0.0.12/go.mod"
+ "github.com/mattn/go-runewidth v0.0.7/go.mod"
+ "github.com/mattn/go-runewidth v0.0.9"
+ "github.com/mattn/go-runewidth v0.0.9/go.mod"
+ "github.com/mattn/go-shellwords v1.0.10"
+ "github.com/mattn/go-shellwords v1.0.10/go.mod"
+ "github.com/saracen/walker v0.1.1"
+ "github.com/saracen/walker v0.1.1/go.mod"
+ "golang.org/x/crypto v0.0.0-20190308221718-c2843e01d9a2"
+ "golang.org/x/crypto v0.0.0-20190308221718-c2843e01d9a2/go.mod"
+ "golang.org/x/crypto v0.0.0-20201016220609-9e8e0b390897"
+ "golang.org/x/crypto v0.0.0-20201016220609-9e8e0b390897/go.mod"
+ "golang.org/x/net v0.0.0-20190404232315-eb5bcb51f2a3/go.mod"
+ "golang.org/x/sync v0.0.0-20200317015054-43a5402ce75a/go.mod"
+ "golang.org/x/sync v0.0.0-20201020160332-67f06af15bc9"
+ "golang.org/x/sync v0.0.0-20201020160332-67f06af15bc9/go.mod"
+ "golang.org/x/sys v0.0.0-20190215142949-d0b11bdaac8a/go.mod"
+ "golang.org/x/sys v0.0.0-20190412213103-97732733099d/go.mod"
+ "golang.org/x/sys v0.0.0-20190626150813-e07cf5db2756"
+ "golang.org/x/sys v0.0.0-20190626150813-e07cf5db2756/go.mod"
+ "golang.org/x/sys v0.0.0-20200116001909-b77594299b42/go.mod"
+ "golang.org/x/sys v0.0.0-20201026173827-119d4633e4d1"
+ "golang.org/x/sys v0.0.0-20201026173827-119d4633e4d1/go.mod"
+ "golang.org/x/text v0.3.0"
+ "golang.org/x/text v0.3.0/go.mod"
+ "golang.org/x/text v0.3.3"
+ "golang.org/x/text v0.3.3/go.mod"
+ "golang.org/x/tools v0.0.0-20180917221912-90fa682c2a6e/go.mod"
+)
+
+go-module_set_globals
+
+SRC_URI="https://github.com/junegunn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ ${EGO_SUM_SRC_URI}"
+
+LICENSE="MIT BSD-with-disclosure"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="tmux? ( app-misc/tmux )"
+
+IUSE="tmux"
+RESTRICT="mirror"
+
+DOCS=( CHANGELOG.md README{,-VIM}.md )
+
+export FZF_VERSION="${PV}" FZF_REVISION="tarball"
+
+src_install() {
+ default
+
+ dobin bin/${PN}
+
+ doman man/man1/${PN}.1
+
+ insinto /usr/share/nvim/runtime/plugin
+ doins plugin/${PN}.vim
+
+ insinto /usr/share/vim/vimfiles/plugin
+ doins plugin/${PN}.vim
+
+ insinto /usr/share/zsh/site-functions
+ newins shell/completion.zsh _${PN}
+
+ newbashcomp shell/completion.bash ${PN}
+
+ insinto /usr/share/${PN}/
+ newins shell/key-bindings.bash ${PN}.bash
+ newins shell/key-bindings.fish ${PN}.fish
+ newins shell/key-bindings.zsh ${PN}.zsh
+
+ if use tmux; then
+ dobin bin/${PN}-tmux
+ doman man/man1/${PN}-tmux.1
+ fi
+}