aboutsummaryrefslogtreecommitdiffstats
path: root/app-shells/fzf/fzf-0.21.1-r1.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-04-26 14:48:09 +0200
committerWynn Wolf Arbor2020-04-26 14:48:09 +0200
commit0c378a92d08608d3e63bf205eafc9de54e01de04 (patch)
tree427ba6c24a0ea053216b01008a2ccdc7abbc1fc8 /app-shells/fzf/fzf-0.21.1-r1.ebuild
parent428fddad58b7f06e89c212b69712074a55f2925d (diff)
downloadpramantha-0c378a92d08608d3e63bf205eafc9de54e01de04.tar.gz
app-shells/fzf: Bump to 0.21.1-r1
Upstream has fixed their Makefile in [1], so we can pull that patch in temporarily and switch over to using make instead of a custom call to go build. This commit also cleans up the ebuild a bit. [1] https://github.com/junegunn/fzf/commit/08c2bcb952a0abbead263dcb002 Package-Manager: Portage-2.3.89, Repoman-2.3.20
Diffstat (limited to 'app-shells/fzf/fzf-0.21.1-r1.ebuild')
-rw-r--r--app-shells/fzf/fzf-0.21.1-r1.ebuild105
1 files changed, 105 insertions, 0 deletions
diff --git a/app-shells/fzf/fzf-0.21.1-r1.ebuild b/app-shells/fzf/fzf-0.21.1-r1.ebuild
new file mode 100644
index 0000000..e618be8
--- /dev/null
+++ b/app-shells/fzf/fzf-0.21.1-r1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="A general-purpose command-line fuzzy finder"
+HOMEPAGE="https://github.com/junegunn/fzf"
+
+EGO_SUM=(
+ "github.com/DATA-DOG/go-sqlmock v1.3.3/go.mod"
+ "github.com/gdamore/encoding v1.0.0"
+ "github.com/gdamore/encoding v1.0.0/go.mod"
+ "github.com/gdamore/tcell v1.3.0"
+ "github.com/gdamore/tcell v1.3.0/go.mod"
+ "github.com/lucasb-eyer/go-colorful v1.0.2"
+ "github.com/lucasb-eyer/go-colorful v1.0.2/go.mod"
+ "github.com/lucasb-eyer/go-colorful v1.0.3"
+ "github.com/lucasb-eyer/go-colorful v1.0.3/go.mod"
+ "github.com/mattn/go-isatty v0.0.12"
+ "github.com/mattn/go-isatty v0.0.12/go.mod"
+ "github.com/mattn/go-runewidth v0.0.4"
+ "github.com/mattn/go-runewidth v0.0.4/go.mod"
+ "github.com/mattn/go-runewidth v0.0.8"
+ "github.com/mattn/go-runewidth v0.0.8/go.mod"
+ "github.com/mattn/go-shellwords v1.0.9"
+ "github.com/mattn/go-shellwords v1.0.9/go.mod"
+ "github.com/saracen/walker v0.0.0-20191201085201-324a081bae7e"
+ "github.com/saracen/walker v0.0.0-20191201085201-324a081bae7e/go.mod"
+ "golang.org/x/crypto v0.0.0-20190308221718-c2843e01d9a2"
+ "golang.org/x/crypto v0.0.0-20190308221718-c2843e01d9a2/go.mod"
+ "golang.org/x/crypto v0.0.0-20200128174031-69ecbb4d6d5d"
+ "golang.org/x/crypto v0.0.0-20200128174031-69ecbb4d6d5d/go.mod"
+ "golang.org/x/net v0.0.0-20190404232315-eb5bcb51f2a3/go.mod"
+ "golang.org/x/net v0.0.0-20190620200207-3b0461eec859"
+ "golang.org/x/net v0.0.0-20190620200207-3b0461eec859/go.mod"
+ "golang.org/x/sync v0.0.0-20190423024810-112230192c58/go.mod"
+ "golang.org/x/sync v0.0.0-20190911185100-cd5d95a43a6e"
+ "golang.org/x/sync v0.0.0-20190911185100-cd5d95a43a6e/go.mod"
+ "golang.org/x/sys v0.0.0-20190215142949-d0b11bdaac8a/go.mod"
+ "golang.org/x/sys v0.0.0-20190412213103-97732733099d/go.mod"
+ "golang.org/x/sys v0.0.0-20190626150813-e07cf5db2756"
+ "golang.org/x/sys v0.0.0-20190626150813-e07cf5db2756/go.mod"
+ "golang.org/x/sys v0.0.0-20200116001909-b77594299b42/go.mod"
+ "golang.org/x/sys v0.0.0-20200202164722-d101bd2416d5"
+ "golang.org/x/sys v0.0.0-20200202164722-d101bd2416d5/go.mod"
+ "golang.org/x/text v0.3.0"
+ "golang.org/x/text v0.3.0/go.mod"
+ "golang.org/x/text v0.3.2"
+ "golang.org/x/text v0.3.2/go.mod"
+ "golang.org/x/tools v0.0.0-20180917221912-90fa682c2a6e/go.mod"
+ "golang.org/x/tools v0.0.0-20191011211836-4c025a95b26e"
+ "golang.org/x/tools v0.0.0-20191011211836-4c025a95b26e/go.mod"
+ "golang.org/x/xerrors v0.0.0-20190717185122-a985d3407aa7/go.mod"
+)
+
+go-module_set_globals
+
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ ${EGO_SUM_SRC_URI}"
+
+LICENSE="MIT BSD-with-disclosure"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="tmux? ( app-misc/tmux )"
+
+IUSE="tmux"
+RESTRICT="mirror"
+
+DOCS=( CHANGELOG.md README{,-VIM}.md )
+
+PATCHES=(
+ "${FILESDIR}/${P}-0001-Quote-LDFLAGS-1995.patch"
+)
+
+src_install() {
+ default
+
+ dobin bin/${PN}
+
+ doman man/man1/${PN}.1
+
+ insinto /usr/share/nvim/runtime/plugin
+ doins plugin/${PN}.vim
+
+ insinto /usr/share/vim/vimfiles/plugin
+ doins plugin/${PN}.vim
+
+ insinto /usr/share/zsh/site-functions
+ newins shell/completion.zsh _${PN}
+
+ newbashcomp shell/completion.bash ${PN}
+
+ insinto /usr/share/${PN}/
+ newins shell/key-bindings.bash ${PN}.bash
+ newins shell/key-bindings.fish ${PN}.fish
+ newins shell/key-bindings.zsh ${PN}.zsh
+
+ if use tmux; then
+ dobin bin/${PN}-tmux
+ doman man/man1/${PN}-tmux.1
+ fi
+}