aboutsummaryrefslogtreecommitdiffstats
path: root/app-portage/bosun/bosun-1.4.0.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2022-10-26 12:55:22 +0200
committerWolfgang Müller2022-10-26 12:55:22 +0200
commit36898917c990ba4446f5d66303812f53f93df815 (patch)
treea8df37645eba49c669486a7da30f7d12ba50180e /app-portage/bosun/bosun-1.4.0.ebuild
parent101b8f490f9a8c91301b8afbeef425c49350a6d6 (diff)
downloadpramantha-36898917c990ba4446f5d66303812f53f93df815.tar.gz
app-portage/bosun: add 1.4.0, drop 1.3.0
Diffstat (limited to 'app-portage/bosun/bosun-1.4.0.ebuild')
-rw-r--r--app-portage/bosun/bosun-1.4.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-portage/bosun/bosun-1.4.0.ebuild b/app-portage/bosun/bosun-1.4.0.ebuild
new file mode 100644
index 0000000..96bfd99
--- /dev/null
+++ b/app-portage/bosun/bosun-1.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Manage portage roles with stow(8)"
+HOMEPAGE="https://git.oriole.systems/bosun"
+SRC_URI="https://git.oriole.systems/${PN}/snapshot/${P}.tar.gz"
+
+RESTRICT="mirror"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-admin/stow"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_compile() { :; }
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins contrib/completion/bosun.fish
+}