aboutsummaryrefslogtreecommitdiffstats
path: root/app-portage/bosun/bosun-1.4.0-r1.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2024-03-30 13:40:41 +0100
committerWolfgang Müller2024-03-30 13:43:46 +0100
commit147ee179b4c21da5a35b6c34e475eef86039ddc6 (patch)
treeb7d5aff83434e611e2965caf408eb9bc1dd99962 /app-portage/bosun/bosun-1.4.0-r1.ebuild
parentb67a015804e40f314aaad8def4a9cf7f41582cba (diff)
downloadpramantha-147ee179b4c21da5a35b6c34e475eef86039ddc6.tar.gz
app-portage/bosun: add 1.4.0.-r1, drop 1.4.0
Migrate to EAPI 8 and support the verify-sig USE flag.
Diffstat (limited to 'app-portage/bosun/bosun-1.4.0-r1.ebuild')
-rw-r--r--app-portage/bosun/bosun-1.4.0-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-portage/bosun/bosun-1.4.0-r1.ebuild b/app-portage/bosun/bosun-1.4.0-r1.ebuild
new file mode 100644
index 0000000..0d8b279
--- /dev/null
+++ b/app-portage/bosun/bosun-1.4.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_METHOD="signify"
+inherit verify-sig
+
+DESCRIPTION="Manage portage roles with stow(8)"
+HOMEPAGE="https://git.oriole.systems/bosun"
+SRC_URI="
+ https://git.oriole.systems/${PN}/snapshot/${P}.tar.gz
+ verify-sig? (
+ https://git.oriole.systems/${PN}/snapshot/${P}.tar.gz.asc
+ -> ${P}.sha.sig
+ )
+"
+
+RESTRICT="mirror"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="app-admin/stow"
+RDEPEND="${DEPEND}"
+
+VERIFY_SIG_OPENPGP_KEY_PATH="/usr/share/signify-keys/oriole-systems-20240330.pub"
+
+src_unpack() {
+ if use verify-sig; then
+ cp "${DISTDIR}"/${P}.{sha.sig,tar.gz} "${WORKDIR}" || die
+ verify-sig_verify_signed_checksums \
+ ${P}.sha.sig sha256 ${P}.tar.gz
+ fi
+ default
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins contrib/completion/bosun.fish
+}