aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/visidata/visidata-2.6.1.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2021-09-30 10:35:08 +0200
committerWolfgang Müller2021-09-30 10:35:08 +0200
commit3ba4a84250b5cf6013a9d825010f1d220f87612f (patch)
tree8a0e024fae43d1d8d9e0e922100ab860067e6a2d /app-office/visidata/visidata-2.6.1.ebuild
parent1c75519ac6b97f32092e9964f93a500d3a411ad8 (diff)
downloadpramantha-3ba4a84250b5cf6013a9d825010f1d220f87612f.tar.gz
app-office/visidata: Bump to 2.6.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3
Diffstat (limited to 'app-office/visidata/visidata-2.6.1.ebuild')
-rw-r--r--app-office/visidata/visidata-2.6.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-office/visidata/visidata-2.6.1.ebuild b/app-office/visidata/visidata-2.6.1.ebuild
new file mode 100644
index 0000000..e329160
--- /dev/null
+++ b/app-office/visidata/visidata-2.6.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_9 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="An interactive multitool for tabular data"
+HOMEPAGE="https://www.visidata.org"
+SRC_URI="https://github.com/saulpw/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+RESTRICT="test"
+
+DEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+pkg_postinst() {
+ optfeature "support for Excel spreadsheets (xls)" dev-python/xlrd
+ optfeature "support for Excel spreadsheets (xlsx)" dev-python/openpyxl
+ optfeature "support for HTML and XML" dev-python/lxml
+ optfeature "support for PNG" dev-python/pypng
+ optfeature "support for Shapefile geographic data (shp)" sci-libs/pyshp
+ optfeature "support for Stata (dta)" dev-python/pandas
+ optfeature "support for TrueType Fonts (ttf)" dev-python/fonttools
+ optfeature "support for YAML" dev-python/pyyaml
+ optfeature "support for all pandas formats" dev-python/pandas
+ optfeature "support for the Hierarchical Data Format (hdf5)" dev-python/h5py
+}