aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/visidata/visidata-2.5.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2021-08-29 11:35:13 +0200
committerWolfgang Müller2021-08-29 11:35:13 +0200
commit2f4925d8a2d678bdeb57a8835ca20a997188bf8a (patch)
treecd6a851e04caa663f7ea81f6170fccb66cbb8a03 /app-office/visidata/visidata-2.5.ebuild
parentaecee2379f575179dd3127b26f5436a5a9e6e0e0 (diff)
downloadpramantha-2f4925d8a2d678bdeb57a8835ca20a997188bf8a.tar.gz
app-office/visidata: Add 2.5
Package-Manager: Portage-3.0.20, Repoman-3.0.3
Diffstat (limited to 'app-office/visidata/visidata-2.5.ebuild')
-rw-r--r--app-office/visidata/visidata-2.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-office/visidata/visidata-2.5.ebuild b/app-office/visidata/visidata-2.5.ebuild
new file mode 100644
index 0000000..e329160
--- /dev/null
+++ b/app-office/visidata/visidata-2.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_9 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="An interactive multitool for tabular data"
+HOMEPAGE="https://www.visidata.org"
+SRC_URI="https://github.com/saulpw/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+RESTRICT="test"
+
+DEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+pkg_postinst() {
+ optfeature "support for Excel spreadsheets (xls)" dev-python/xlrd
+ optfeature "support for Excel spreadsheets (xlsx)" dev-python/openpyxl
+ optfeature "support for HTML and XML" dev-python/lxml
+ optfeature "support for PNG" dev-python/pypng
+ optfeature "support for Shapefile geographic data (shp)" sci-libs/pyshp
+ optfeature "support for Stata (dta)" dev-python/pandas
+ optfeature "support for TrueType Fonts (ttf)" dev-python/fonttools
+ optfeature "support for YAML" dev-python/pyyaml
+ optfeature "support for all pandas formats" dev-python/pandas
+ optfeature "support for the Hierarchical Data Format (hdf5)" dev-python/h5py
+}