aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/visidata/visidata-2.10.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2022-09-03 10:25:57 +0200
committerWolfgang Müller2022-09-03 10:25:57 +0200
commit531d2953241e82eed112ab1ea3ed46bc585a27f3 (patch)
tree7c5ec64a521c6c8d8366cd3a6a75e6e6a4d96a64 /app-office/visidata/visidata-2.10.ebuild
parentb10fef97e10f301e24b65b6fd4d5fafc14569ed2 (diff)
downloadpramantha-531d2953241e82eed112ab1ea3ed46bc585a27f3.tar.gz
app-office/visidata: add 2.10, drop 2.8
Diffstat (limited to 'app-office/visidata/visidata-2.10.ebuild')
-rw-r--r--app-office/visidata/visidata-2.10.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-office/visidata/visidata-2.10.ebuild b/app-office/visidata/visidata-2.10.ebuild
new file mode 100644
index 0000000..45b31f5
--- /dev/null
+++ b/app-office/visidata/visidata-2.10.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10,11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="An interactive multitool for tabular data"
+HOMEPAGE="https://www.visidata.org"
+SRC_URI="https://github.com/saulpw/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+RESTRICT="test"
+
+DEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+pkg_postinst() {
+ optfeature "support for Excel spreadsheets (xls)" dev-python/xlrd
+ optfeature "support for Excel spreadsheets (xlsx)" dev-python/openpyxl
+ optfeature "support for HTML and XML" dev-python/lxml
+ optfeature "support for PNG" dev-python/pypng
+ optfeature "support for Shapefile geographic data (shp)" sci-libs/pyshp
+ optfeature "support for Stata (dta)" dev-python/pandas
+ optfeature "support for TrueType Fonts (ttf)" dev-python/fonttools
+ optfeature "support for YAML" dev-python/pyyaml
+ optfeature "support for all pandas formats" dev-python/pandas
+ optfeature "support for the Hierarchical Data Format (hdf5)" dev-python/h5py
+}