aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/visidata/visidata-2.10.1.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2022-09-15 14:56:51 +0200
committerWolfgang Müller2022-09-15 14:56:51 +0200
commitbcfc8dac59f3f712e18e340cd55e3ecea639560b (patch)
treea2e5ee0e7acb68303d3e46e10d0ddc3123868a82 /app-office/visidata/visidata-2.10.1.ebuild
parent531d2953241e82eed112ab1ea3ed46bc585a27f3 (diff)
downloadpramantha-bcfc8dac59f3f712e18e340cd55e3ecea639560b.tar.gz
app-office/visidata: add 2.10.1, drop 2.10
Diffstat (limited to 'app-office/visidata/visidata-2.10.1.ebuild')
-rw-r--r--app-office/visidata/visidata-2.10.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-office/visidata/visidata-2.10.1.ebuild b/app-office/visidata/visidata-2.10.1.ebuild
new file mode 100644
index 0000000..580ef91
--- /dev/null
+++ b/app-office/visidata/visidata-2.10.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10,11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="An interactive multitool for tabular data"
+HOMEPAGE="https://www.visidata.org"
+SRC_URI="https://github.com/saulpw/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+RESTRICT="test"
+
+DEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+pkg_postinst() {
+ optfeature "support for Excel spreadsheets (xls)" dev-python/xlrd
+ optfeature "support for Excel spreadsheets (xlsx)" dev-python/openpyxl
+ optfeature "support for HTML and XML" dev-python/lxml
+ optfeature "support for PNG" dev-python/pypng
+ optfeature "support for Shapefile geographic data (shp)" sci-libs/pyshp
+ optfeature "support for Stata (dta)" dev-python/pandas
+ optfeature "support for TrueType Fonts (ttf)" dev-python/fonttools
+ optfeature "support for YAML" dev-python/pyyaml
+ optfeature "support for all pandas formats" dev-python/pandas
+ optfeature "support for the Hierarchical Data Format (hdf5)" dev-python/h5py
+}