aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/fava/fava-1.26.2.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2024-01-01 11:15:09 +0100
committerWolfgang Müller2024-01-01 11:15:09 +0100
commita2c9f4f3fd005ecbab437712a04c194faf763944 (patch)
tree3473c8fffb48ce03874ebed2522c37936e711613 /app-office/fava/fava-1.26.2.ebuild
parent3eba36342572b40b8451a632f2a07e15a6618abc (diff)
downloadpramantha-a2c9f4f3fd005ecbab437712a04c194faf763944.tar.gz
app-office/fava: add 1.26.4, drop 1.26.2
Diffstat (limited to 'app-office/fava/fava-1.26.2.ebuild')
-rw-r--r--app-office/fava/fava-1.26.2.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/app-office/fava/fava-1.26.2.ebuild b/app-office/fava/fava-1.26.2.ebuild
deleted file mode 100644
index 9affd4b..0000000
--- a/app-office/fava/fava-1.26.2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{10,11} )
-DISTUTILS_USE_PEP517=setuptools
-DISTUTILS_SINGLE_IMPL=1
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Web interface for the accounting tool Beancount"
-HOMEPAGE="https://beancount.github.io/fava/ https://pypi.org/project/fava/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=app-office/beancount-2.3.5[${PYTHON_SINGLE_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/Babel-2.7.0[${PYTHON_USEDEP}]
- >=dev-python/cheroot-8.5.2[${PYTHON_USEDEP}]
- >=dev-python/flask-babel-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/flask-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.0.1[${PYTHON_USEDEP}]
- >=dev-python/click-8.0.1[${PYTHON_USEDEP}]
- >=dev-python/markdown2-2.3.0[${PYTHON_USEDEP}]
- dev-python/ply[${PYTHON_USEDEP}]
- >=dev-python/simplejson-3.16.0[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-2.3.0[${PYTHON_USEDEP}]
- dev-python/chardet[${PYTHON_USEDEP}]
- ')
- "
-
-python_prepare_all() {
- sed -i -e 's:build-backend = "_build_backend":build-backend = "setuptools.build_meta":' pyproject.toml || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # test_static_url presumes and requires the existence of these two files.
- # They need only to exist in order for the code to determine the mtime
- # value.
- mkdir -p fava/static/{javascript,css} || die
- touch fava/static/javascript/main.ts || die
- touch fava/static/css/style.css || die
-
- py.test -v || die
-}