aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/fava/fava-1.26.2.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2023-10-30 20:26:19 +0100
committerWolfgang Müller2023-10-30 20:26:19 +0100
commit20b85f6becbcfd199b35d84fbe28221708a405f9 (patch)
treee03565b38ad64a98a846f01ccbfcb1e54e8f3fd4 /app-office/fava/fava-1.26.2.ebuild
parentf5a55b27c71a8bf0ce2e265661a8609f5d2cf087 (diff)
downloadpramantha-20b85f6becbcfd199b35d84fbe28221708a405f9.tar.gz
Revert "app-office/fava: add 1.26.2, drop 1.26.1"
This reverts commit f5a55b27c71a8bf0ce2e265661a8609f5d2cf087.
Diffstat (limited to 'app-office/fava/fava-1.26.2.ebuild')
-rw-r--r--app-office/fava/fava-1.26.2.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/app-office/fava/fava-1.26.2.ebuild b/app-office/fava/fava-1.26.2.ebuild
deleted file mode 100644
index 6ca84a1..0000000
--- a/app-office/fava/fava-1.26.2.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{10,11} )
-DISTUTILS_USE_PEP517=setuptools
-DISTUTILS_SINGLE_IMPL=1
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Web interface for the accounting tool Beancount"
-HOMEPAGE="https://beancount.github.io/fava/ https://pypi.org/project/fava/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=app-office/beancount-2.3.5[${PYTHON_SINGLE_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/Babel-2.7.0[${PYTHON_USEDEP}]
- >=dev-python/cheroot-8.5.2[${PYTHON_USEDEP}]
- >=dev-python/flask-babel-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/flask-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.0.1[${PYTHON_USEDEP}]
- >=dev-python/click-8.0.1[${PYTHON_USEDEP}]
- >=dev-python/markdown2-2.3.0[${PYTHON_USEDEP}]
- dev-python/ply[${PYTHON_USEDEP}]
- >=dev-python/simplejson-3.16.0[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-2.3.0[${PYTHON_USEDEP}]
- dev-python/chardet[${PYTHON_USEDEP}]
- ')
- "
-
-python_test() {
- # test_static_url presumes and requires the existence of these two files.
- # They need only to exist in order for the code to determine the mtime
- # value.
- mkdir -p fava/static/{javascript,css} || die
- touch fava/static/javascript/main.ts || die
- touch fava/static/css/style.css || die
-
- py.test -v || die
-}