aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/fava/fava-1.24.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2023-03-30 11:27:34 +0200
committerWolfgang Müller2023-03-30 11:27:34 +0200
commitbb8b77f206d6248df58a5a46bc8be79d3e490131 (patch)
treef4545e3335d1465ec459a2662c0d35faf63e6250 /app-office/fava/fava-1.24.ebuild
parent836dd10f7d71bd660fb9b3f08c8800acbb021b28 (diff)
downloadpramantha-bb8b77f206d6248df58a5a46bc8be79d3e490131.tar.gz
app-office/fava: add 1.24.1, drop 1.24
Diffstat (limited to 'app-office/fava/fava-1.24.ebuild')
-rw-r--r--app-office/fava/fava-1.24.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/app-office/fava/fava-1.24.ebuild b/app-office/fava/fava-1.24.ebuild
deleted file mode 100644
index a03c987..0000000
--- a/app-office/fava/fava-1.24.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{10,11} )
-DISTUTILS_USE_PEP517=setuptools
-DISTUTILS_SINGLE_IMPL=1
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Web interface for the accounting tool Beancount"
-HOMEPAGE="https://beancount.github.io/fava/ https://pypi.org/project/fava/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=app-office/beancount-2.3.0[${PYTHON_SINGLE_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/Babel-2.7.0[${PYTHON_USEDEP}]
- >=dev-python/cheroot-8.5.2[${PYTHON_USEDEP}]
- >=dev-python/flask-babel-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/flask-2.0.1[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.0.1[${PYTHON_USEDEP}]
- >=dev-python/click-8.0.1[${PYTHON_USEDEP}]
- >=dev-python/markdown2-2.3.0[${PYTHON_USEDEP}]
- dev-python/ply[${PYTHON_USEDEP}]
- >=dev-python/simplejson-3.16.0[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-1.0.0[${PYTHON_USEDEP}]
- dev-python/chardet[${PYTHON_USEDEP}]
- ')
- "
-
-python_test() {
- # test_static_url presumes and requires the existence of these two files.
- # They need only to exist in order for the code to determine the mtime
- # value.
- mkdir -p fava/static/{javascript,css} || die
- touch fava/static/javascript/main.ts || die
- touch fava/static/css/style.css || die
-
- py.test -v || die
-}