aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/fava/fava-1.24.1.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2023-04-20 10:33:49 +0200
committerWolfgang Müller2023-04-20 10:33:49 +0200
commit2f284ac16a9b04b172bf41d65986ee3b34c0e399 (patch)
tree05f2acbc61498f50e1130b135c1d2caa2789710c /app-office/fava/fava-1.24.1.ebuild
parentcadf37848a7ab65f8972351df5969a0ed2281cef (diff)
downloadpramantha-2f284ac16a9b04b172bf41d65986ee3b34c0e399.tar.gz
app-office/fava: add 1.24.4, drop 1.24.1
Diffstat (limited to 'app-office/fava/fava-1.24.1.ebuild')
-rw-r--r--app-office/fava/fava-1.24.1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/app-office/fava/fava-1.24.1.ebuild b/app-office/fava/fava-1.24.1.ebuild
deleted file mode 100644
index a03c987..0000000
--- a/app-office/fava/fava-1.24.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{10,11} )
-DISTUTILS_USE_PEP517=setuptools
-DISTUTILS_SINGLE_IMPL=1
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Web interface for the accounting tool Beancount"
-HOMEPAGE="https://beancount.github.io/fava/ https://pypi.org/project/fava/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=app-office/beancount-2.3.0[${PYTHON_SINGLE_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/Babel-2.7.0[${PYTHON_USEDEP}]
- >=dev-python/cheroot-8.5.2[${PYTHON_USEDEP}]
- >=dev-python/flask-babel-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/flask-2.0.1[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.0.1[${PYTHON_USEDEP}]
- >=dev-python/click-8.0.1[${PYTHON_USEDEP}]
- >=dev-python/markdown2-2.3.0[${PYTHON_USEDEP}]
- dev-python/ply[${PYTHON_USEDEP}]
- >=dev-python/simplejson-3.16.0[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-1.0.0[${PYTHON_USEDEP}]
- dev-python/chardet[${PYTHON_USEDEP}]
- ')
- "
-
-python_test() {
- # test_static_url presumes and requires the existence of these two files.
- # They need only to exist in order for the code to determine the mtime
- # value.
- mkdir -p fava/static/{javascript,css} || die
- touch fava/static/javascript/main.ts || die
- touch fava/static/css/style.css || die
-
- py.test -v || die
-}