aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/fava/fava-1.22.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2022-07-16 12:31:48 +0200
committerWolfgang Müller2022-07-16 12:31:48 +0200
commit45dfa0523f2b70d47d0f9723542103b977a49b35 (patch)
treeb738fad3e6114b26ab493c1b4b98aaa6e11261d4 /app-office/fava/fava-1.22.ebuild
parent478b85a49662f84f0564f33dd856d557fd43c264 (diff)
downloadpramantha-45dfa0523f2b70d47d0f9723542103b977a49b35.tar.gz
app-office/fava: add 1.22.1, drop 1.22
Diffstat (limited to 'app-office/fava/fava-1.22.ebuild')
-rw-r--r--app-office/fava/fava-1.22.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/app-office/fava/fava-1.22.ebuild b/app-office/fava/fava-1.22.ebuild
deleted file mode 100644
index 59b50cc..0000000
--- a/app-office/fava/fava-1.22.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{9,10} )
-
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-
-inherit distutils-r1
-
-DESCRIPTION="Web interface for the accounting tool Beancount"
-HOMEPAGE="https://beancount.github.io/fava/ https://pypi.org/project/fava/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- >=app-office/beancount-2.3.0[${PYTHON_USEDEP}]
- >=dev-python/Babel-2.7.0[${PYTHON_USEDEP}]
- >=dev-python/cheroot-8.5.2[${PYTHON_USEDEP}]
- >=dev-python/flask-babel-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/flask-2.0.1[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.0.1[${PYTHON_USEDEP}]
- >=dev-python/click-8.0.1[${PYTHON_USEDEP}]
- >=dev-python/markdown2-2.3.0[${PYTHON_USEDEP}]
- dev-python/ply[${PYTHON_USEDEP}]
- >=dev-python/simplejson-3.16.0[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-1.0.0[${PYTHON_USEDEP}]
- dev-python/chardet[${PYTHON_USEDEP}]
- "
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_test() {
- # test_static_url presumes and requires the existence of these two files.
- # They need only to exist in order for the code to determine the mtime
- # value.
- mkdir -p fava/static/{javascript,css} || die
- touch fava/static/javascript/main.ts || die
- touch fava/static/css/style.css || die
-
- py.test -v || die
-}