aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/fava/fava-1.20.1.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2022-02-24 11:22:44 +0100
committerWolfgang Müller2022-02-24 11:22:44 +0100
commit0e9159bc33c7e4b273632c1ccab213cc0f07dcb8 (patch)
treeddc27e1b1eabd8d519cc143f5a2faf5976f00968 /app-office/fava/fava-1.20.1.ebuild
parent9bd3b039b1b687b2a18c3b274d4de055bd262f0f (diff)
downloadpramantha-0e9159bc33c7e4b273632c1ccab213cc0f07dcb8.tar.gz
app-office/fava: Bump to 1.21
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Diffstat (limited to 'app-office/fava/fava-1.20.1.ebuild')
-rw-r--r--app-office/fava/fava-1.20.1.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/app-office/fava/fava-1.20.1.ebuild b/app-office/fava/fava-1.20.1.ebuild
deleted file mode 100644
index 40aa466..0000000
--- a/app-office/fava/fava-1.20.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_9 )
-
-inherit distutils-r1 elisp-common
-
-DESCRIPTION="Web interface for the accounting tool Beancount"
-HOMEPAGE="https://beancount.github.io/fava/ https://pypi.org/project/fava/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- >=app-office/beancount-2.3.0[${PYTHON_USEDEP}]
- >=dev-python/Babel-2.7.0[${PYTHON_USEDEP}]
- >=dev-python/cheroot-8.5.2[${PYTHON_USEDEP}]
- >=dev-python/flask-babel-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/flask-2.0.1[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.0.1[${PYTHON_USEDEP}]
- >=dev-python/click-8.0.1[${PYTHON_USEDEP}]
- >=dev-python/markdown2-2.3.0[${PYTHON_USEDEP}]
- dev-python/ply[${PYTHON_USEDEP}]
- >=dev-python/simplejson-3.16.0[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-1.0.0[${PYTHON_USEDEP}]
- dev-python/chardet[${PYTHON_USEDEP}]
- "
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_test() {
- # test_static_url presumes and requires the existence of these two files.
- # They need only to exist in order for the code to determine the mtime
- # value.
- mkdir -p fava/static/{javascript,css} || die
- touch fava/static/javascript/main.ts || die
- touch fava/static/css/style.css || die
-
- py.test -v || die
-}