aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/fava/fava-1.19-r1.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2021-09-07 13:06:28 +0200
committerWolfgang Müller2021-09-07 13:06:28 +0200
commit3513628ae3481fdf7cee8745a00403d8c002a7b7 (patch)
treed187e24c60c87610066dfe32b982a1278fb8ce8c /app-office/fava/fava-1.19-r1.ebuild
parent2f4925d8a2d678bdeb57a8835ca20a997188bf8a (diff)
downloadpramantha-3513628ae3481fdf7cee8745a00403d8c002a7b7.tar.gz
app-office/fava: Add dependency for dev-python/chardet
Setting up fava on a WSL 2 installation of Gentoo revealed this previously undocumented dependency. Make sure we actually pull it in. Package-Manager: Portage-3.0.20, Repoman-3.0.3
Diffstat (limited to 'app-office/fava/fava-1.19-r1.ebuild')
-rw-r--r--app-office/fava/fava-1.19-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-office/fava/fava-1.19-r1.ebuild b/app-office/fava/fava-1.19-r1.ebuild
new file mode 100644
index 0000000..452bff3
--- /dev/null
+++ b/app-office/fava/fava-1.19-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8,9} )
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1 elisp-common
+
+DESCRIPTION="Web interface for the accounting tool Beancount"
+HOMEPAGE="https://beancount.github.io/fava/ https://pypi.org/project/fava/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ >=app-office/beancount-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.6.0[${PYTHON_USEDEP}]
+ dev-python/cheroot[${PYTHON_USEDEP}]
+ >=dev-python/flask-babel-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ >=dev-python/markdown2-2.3.0[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-1.0.0[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ "
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ # test_static_url presumes and requires the existence of these two files.
+ # They need only to exist in order for the code to determine the mtime
+ # value.
+ mkdir -p fava/static/{javascript,css} || die
+ touch fava/static/javascript/main.ts || die
+ touch fava/static/css/style.css || die
+
+ py.test -v || die
+}