aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/fava/fava-1.19-r1.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2021-09-30 10:32:30 +0200
committerWolfgang Müller2021-09-30 10:32:30 +0200
commit1c75519ac6b97f32092e9964f93a500d3a411ad8 (patch)
tree09130bf223faa8626f89895e747765159fd13bce /app-office/fava/fava-1.19-r1.ebuild
parent351ef5b6f11e4af9dfec336c4fa248bfdc67d484 (diff)
downloadpramantha-1c75519ac6b97f32092e9964f93a500d3a411ad8.tar.gz
app-office/fava: Bump to 1.20.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3
Diffstat (limited to 'app-office/fava/fava-1.19-r1.ebuild')
-rw-r--r--app-office/fava/fava-1.19-r1.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/app-office/fava/fava-1.19-r1.ebuild b/app-office/fava/fava-1.19-r1.ebuild
deleted file mode 100644
index 452bff3..0000000
--- a/app-office/fava/fava-1.19-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{8,9} )
-DISTUTILS_USE_SETUPTOOLS="rdepend"
-
-inherit distutils-r1 elisp-common
-
-DESCRIPTION="Web interface for the accounting tool Beancount"
-HOMEPAGE="https://beancount.github.io/fava/ https://pypi.org/project/fava/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- >=app-office/beancount-2.3.0[${PYTHON_USEDEP}]
- >=dev-python/Babel-2.6.0[${PYTHON_USEDEP}]
- dev-python/cheroot[${PYTHON_USEDEP}]
- >=dev-python/flask-babel-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/flask-0.10.1[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.10[${PYTHON_USEDEP}]
- dev-python/click[${PYTHON_USEDEP}]
- >=dev-python/markdown2-2.3.0[${PYTHON_USEDEP}]
- dev-python/ply[${PYTHON_USEDEP}]
- >=dev-python/simplejson-3.2.0[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-1.0.0[${PYTHON_USEDEP}]
- dev-python/chardet[${PYTHON_USEDEP}]
- "
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_test() {
- # test_static_url presumes and requires the existence of these two files.
- # They need only to exist in order for the code to determine the mtime
- # value.
- mkdir -p fava/static/{javascript,css} || die
- touch fava/static/javascript/main.ts || die
- touch fava/static/css/style.css || die
-
- py.test -v || die
-}