aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/fava/fava-1.17-r1.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2021-01-22 12:52:44 +0100
committerWynn Wolf Arbor2021-01-22 12:52:44 +0100
commitb899218a8a2a7986ccc8b8ccc74a82fc88945a41 (patch)
treeb1362e08126b4afb7c1dffa0ce0b9a85f1e59272 /app-office/fava/fava-1.17-r1.ebuild
parent4de197994bcc16d2df1edc74b6b3415c6070e2e5 (diff)
downloadpramantha-b899218a8a2a7986ccc8b8ccc74a82fc88945a41.tar.gz
app-office/fava: Bump to 1.18
Package-Manager: Portage-3.0.13, Repoman-3.0.2
Diffstat (limited to 'app-office/fava/fava-1.17-r1.ebuild')
-rw-r--r--app-office/fava/fava-1.17-r1.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/app-office/fava/fava-1.17-r1.ebuild b/app-office/fava/fava-1.17-r1.ebuild
deleted file mode 100644
index 3df1675..0000000
--- a/app-office/fava/fava-1.17-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{8,9} )
-DISTUTILS_USE_SETUPTOOLS="rdepend"
-
-inherit distutils-r1 elisp-common
-
-DESCRIPTION="Web interface for the accounting tool Beancount"
-HOMEPAGE="https://beancount.github.io/fava/ https://pypi.org/project/fava/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- >=app-office/beancount-2.3.0[${PYTHON_USEDEP}]
- >=dev-python/Babel-2.6.0[${PYTHON_USEDEP}]
- dev-python/cheroot[${PYTHON_USEDEP}]
- >=dev-python/flask-babel-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/flask-0.10.1[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.10[${PYTHON_USEDEP}]
- dev-python/click[${PYTHON_USEDEP}]
- >=dev-python/markdown2-2.3.0[${PYTHON_USEDEP}]
- dev-python/ply[${PYTHON_USEDEP}]
- >=dev-python/simplejson-2.3.0[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-0.15.0[${PYTHON_USEDEP}]
- "
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_test() {
- # test_static_url presumes and requires the existence of these two files.
- # They need only to exist in order for the code to determine the mtime
- # value.
- mkdir -p fava/static/{javascript,css} || die
- touch fava/static/javascript/main.ts || die
- touch fava/static/css/style.css || die
-
- py.test -v || die
-}