aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/fava/fava-1.16.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-11-15 18:24:26 +0100
committerWynn Wolf Arbor2020-11-15 18:24:26 +0100
commit8b08e67c020536cc8f21adf807b3a0e9f0dbc754 (patch)
tree44742a013c0c81cfd5718938d46fea080d41a243 /app-office/fava/fava-1.16.ebuild
parentb058120c8d6d762fdff889db02399b01e8ebc6d8 (diff)
downloadpramantha-8b08e67c020536cc8f21adf807b3a0e9f0dbc754.tar.gz
app-office/fava: Bump to 1.17
Package-Manager: Portage-3.0.8, Repoman-3.0.2
Diffstat (limited to 'app-office/fava/fava-1.16.ebuild')
-rw-r--r--app-office/fava/fava-1.16.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/app-office/fava/fava-1.16.ebuild b/app-office/fava/fava-1.16.ebuild
deleted file mode 100644
index a318569..0000000
--- a/app-office/fava/fava-1.16.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-DISTUTILS_USE_SETUPTOOLS="rdepend"
-
-inherit distutils-r1 elisp-common
-
-DESCRIPTION="Web interface for the accounting tool Beancount"
-HOMEPAGE="https://beancount.github.io/fava/ https://pypi.org/project/fava/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- >=app-office/beancount-2.3.0[${PYTHON_USEDEP}]
- >=dev-python/Babel-2.6.0[${PYTHON_USEDEP}]
- dev-python/cheroot[${PYTHON_USEDEP}]
- >=dev-python/flask-babel-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/flask-0.10.1[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.10[${PYTHON_USEDEP}]
- dev-python/click[${PYTHON_USEDEP}]
- >=dev-python/markdown2-2.3.0[${PYTHON_USEDEP}]
- dev-python/ply[${PYTHON_USEDEP}]
- >=dev-python/simplejson-2.3.0[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-0.15.0[${PYTHON_USEDEP}]
- "
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_test() {
- # test_static_url presumes and requires the existence of these two files.
- # They need only to exist in order for the code to determine the mtime
- # value.
- mkdir -p fava/static/{javascript,css} || die
- touch fava/static/javascript/main.ts || die
- touch fava/static/css/style.css || die
-
- py.test -v || die
-}