aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/fava/fava-1.15.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-10-21 15:01:36 +0200
committerWynn Wolf Arbor2020-10-21 15:01:36 +0200
commitef5b97072c1e748ad26356594c3e08c385e8f264 (patch)
treee852baccc96aa0080817d04d08b43ea2932640ac /app-office/fava/fava-1.15.ebuild
parent3aa0108d22bf5909d5e33646063bdaf75d0bef8e (diff)
downloadpramantha-ef5b97072c1e748ad26356594c3e08c385e8f264.tar.gz
app-office/fava: Bump to 1.16
Package-Manager: Portage-3.0.8, Repoman-3.0.2
Diffstat (limited to 'app-office/fava/fava-1.15.ebuild')
-rw-r--r--app-office/fava/fava-1.15.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/app-office/fava/fava-1.15.ebuild b/app-office/fava/fava-1.15.ebuild
deleted file mode 100644
index cc0f8f9..0000000
--- a/app-office/fava/fava-1.15.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-DISTUTILS_USE_SETUPTOOLS="rdepend"
-
-inherit distutils-r1 elisp-common
-
-DESCRIPTION="Web interface for the accounting tool Beancount"
-HOMEPAGE="https://beancount.github.io/fava/ https://pypi.org/project/fava/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- >=app-office/beancount-2.1.3[${PYTHON_USEDEP}]
- >=dev-python/Babel-2.6.0[${PYTHON_USEDEP}]
- dev-python/cheroot[${PYTHON_USEDEP}]
- >=dev-python/flask-babel-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/flask-0.10.1[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.10[${PYTHON_USEDEP}]
- dev-python/click[${PYTHON_USEDEP}]
- >=dev-python/markdown2-2.3.0[${PYTHON_USEDEP}]
- dev-python/ply[${PYTHON_USEDEP}]
- >=dev-python/simplejson-2.3.0[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-0.15.0[${PYTHON_USEDEP}]
- dev-python/jaraco-functools[${PYTHON_USEDEP}]
- "
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_test() {
- # test_static_url presumes and requires the existence of these two files.
- # They need only to exist in order for the code to determine the mtime
- # value.
- mkdir -p fava/static/{javascript,css} || die
- touch fava/static/javascript/main.ts || die
- touch fava/static/css/style.css || die
-
- py.test -v || die
-}