aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/fava/fava-1.14.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-02-19 20:12:27 +0100
committerWynn Wolf Arbor2020-02-19 20:12:27 +0100
commit75dc04a91cf0eb6019db7eab09becf952db36d7a (patch)
treed20cf5ab4709fc6c6bd37f5b2e2947eeff0224c2 /app-office/fava/fava-1.14.ebuild
parente46f2078c77bace61f68dea97119026157d954ad (diff)
downloadpramantha-75dc04a91cf0eb6019db7eab09becf952db36d7a.tar.gz
app-office/fava: Bump to 1.14
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Diffstat (limited to 'app-office/fava/fava-1.14.ebuild')
-rw-r--r--app-office/fava/fava-1.14.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-office/fava/fava-1.14.ebuild b/app-office/fava/fava-1.14.ebuild
new file mode 100644
index 0000000..4d9cf26
--- /dev/null
+++ b/app-office/fava/fava-1.14.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 )
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1 elisp-common
+
+DESCRIPTION="Web interface for the accounting tool Beancount"
+HOMEPAGE="https://beancount.github.io/fava/ https://pypi.org/project/fava/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=app-office/beancount-2.1.3[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.6.0[${PYTHON_USEDEP}]
+ dev-python/cheroot[${PYTHON_USEDEP}]
+ >=dev-python/flask-babel-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ >=dev-python/markdown2-2.3.0[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-0.15.0[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ "
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"