aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/beancount/beancount-2.3.4.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2022-02-24 11:18:04 +0100
committerWolfgang Müller2022-02-24 11:18:04 +0100
commit9bd3b039b1b687b2a18c3b274d4de055bd262f0f (patch)
tree2e79e4559ad48d791778765ed389b69a477497c5 /app-office/beancount/beancount-2.3.4.ebuild
parent4f411f3ecc1b2ab8e0d09c444e6b483648f4872f (diff)
downloadpramantha-9bd3b039b1b687b2a18c3b274d4de055bd262f0f.tar.gz
app-office/beancount: Bump to 2.3.5
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Diffstat (limited to 'app-office/beancount/beancount-2.3.4.ebuild')
-rw-r--r--app-office/beancount/beancount-2.3.4.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/app-office/beancount/beancount-2.3.4.ebuild b/app-office/beancount/beancount-2.3.4.ebuild
deleted file mode 100644
index 2f40006..0000000
--- a/app-office/beancount/beancount-2.3.4.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS="rdepend"
-
-inherit distutils-r1 elisp-common
-
-DESCRIPTION="Command-line Double-Entry Accounting"
-HOMEPAGE="http://furius.ca/beancount https://pypi.org/project/beancount"
-
-if [[ ${PV} == 9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/beancount/beancount"
- EGIT_BRANCH="v2"
- KEYWORDS=""
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="amd64 x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="emacs"
-
-SITEFILE="50{PN}-mode-gentoo.el"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/beautifulsoup4[${PYTHON_USEDEP}]
- >=dev-python/bottle-0.12[${PYTHON_USEDEP}]
- >=dev-python/google-api-python-client-1.8.2[${PYTHON_USEDEP}]
- >=dev-python/httplib2-0.10[${PYTHON_USEDEP}]
- >=dev-python/lxml-3.0[${PYTHON_USEDEP}]
- >=dev-python/oauth2client-4.0[${PYTHON_USEDEP}]
- >=dev-python/ply-3.4[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.6.0[${PYTHON_USEDEP}]
- >=dev-python/python-magic-0.4.12[${PYTHON_USEDEP}]
- >=dev-python/requests-2.0[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- ')
-"
-
-python_compile_all() {
- use emacs && elisp-compile editors/emacs/beancount.el
-}
-
-python_install_all() {
- rm -rf "${ED}/usr/elisp" || die "removing erroneous elisp files failed"
-
- distutils-r1_python_install_all
-
- if use emacs; then
- elisp-install ${PN} editors/emacs/beancount.el
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-}