aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/beancount/beancount-2.3.3.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2021-03-25 14:14:02 +0100
committerWolfgang Müller2021-03-25 14:14:02 +0100
commitaeaf03f6c79a217089e0b75282d45f74ba2aa6c8 (patch)
tree911ce685353a43ef7b1a91aa0e4f402c9466b762 /app-office/beancount/beancount-2.3.3.ebuild
parent321508de8cd51cb5e64cf781b810cfa52709efe8 (diff)
downloadpramantha-aeaf03f6c79a217089e0b75282d45f74ba2aa6c8.tar.gz
app-office/beancount: Bump to 2.3.4
Package-Manager: Portage-3.0.13, Repoman-3.0.2
Diffstat (limited to 'app-office/beancount/beancount-2.3.3.ebuild')
-rw-r--r--app-office/beancount/beancount-2.3.3.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/app-office/beancount/beancount-2.3.3.ebuild b/app-office/beancount/beancount-2.3.3.ebuild
deleted file mode 100644
index 18a460d..0000000
--- a/app-office/beancount/beancount-2.3.3.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS="rdepend"
-
-inherit distutils-r1 elisp-common
-
-DESCRIPTION="Command-line Double-Entry Accounting"
-HOMEPAGE="http://furius.ca/beancount https://pypi.org/project/beancount"
-
-if [[ ${PV} == 9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/beancount/beancount"
- EGIT_BRANCH="v2"
- KEYWORDS=""
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="amd64 x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="emacs"
-
-SITEFILE="50{PN}-mode-gentoo.el"
-
-RDEPEND="
- $(python_gen_cond_dep '
- >=dev-python/beautifulsoup-4[${PYTHON_USEDEP}]
- >=dev-python/bottle-0.12[${PYTHON_USEDEP}]
- >=dev-python/google-api-python-client-1.8.2[${PYTHON_USEDEP}]
- >=dev-python/httplib2-0.10[${PYTHON_USEDEP}]
- >=dev-python/lxml-3.0[${PYTHON_USEDEP}]
- >=dev-python/oauth2client-4.0[${PYTHON_USEDEP}]
- >=dev-python/ply-3.4[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.6.0[${PYTHON_USEDEP}]
- >=dev-python/python-magic-0.4.12[${PYTHON_USEDEP}]
- >=dev-python/requests-2.0[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- ')
-"
-
-python_compile_all() {
- use emacs && elisp-compile editors/emacs/beancount.el
-}
-
-python_install_all() {
- rm -rf "${ED}/usr/elisp" || die "removing erroneous elisp files failed"
-
- distutils-r1_python_install_all
-
- if use emacs; then
- elisp-install ${PN} editors/emacs/beancount.el
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-}