aboutsummaryrefslogtreecommitdiffstats
path: root/app-editors/kakoune/kakoune-2021.08.28.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2021-08-28 09:07:13 +0200
committerWolfgang Müller2021-08-28 09:07:13 +0200
commitaecee2379f575179dd3127b26f5436a5a9e6e0e0 (patch)
tree49c14d5195477e32ba410d6baeb6a98f947dcc67 /app-editors/kakoune/kakoune-2021.08.28.ebuild
parent9a95597be1a4c40c6943e88a04fa795f3443b97e (diff)
downloadpramantha-aecee2379f575179dd3127b26f5436a5a9e6e0e0.tar.gz
app-editors/kakoune: Bump to 2021.08.28
Package-Manager: Portage-3.0.20, Repoman-3.0.3
Diffstat (limited to 'app-editors/kakoune/kakoune-2021.08.28.ebuild')
-rw-r--r--app-editors/kakoune/kakoune-2021.08.28.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-editors/kakoune/kakoune-2021.08.28.ebuild b/app-editors/kakoune/kakoune-2021.08.28.ebuild
new file mode 100644
index 0000000..a092062
--- /dev/null
+++ b/app-editors/kakoune/kakoune-2021.08.28.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mawww/kakoune.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/mawww/kakoune/releases/download/v${PV}/kakoune-${PV}.tar.bz2"
+ KEYWORDS="amd64"
+ RESTRICT="mirror"
+fi
+
+DESCRIPTION="Selection-oriented code editor inspired by vim"
+HOMEPAGE="https://kakoune.org"
+
+LICENSE="Unlicense"
+SLOT="0"
+IUSE="debug static"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="sys-libs/ncurses:0=[unicode]"
+DEPEND="${RDEPEND} virtual/pkgconfig"
+
+src_configure() {
+ tc-export CXX
+ export debug=$(usex debug)
+ export static=$(usex static)
+}
+
+src_compile() {
+ emake -C src
+}
+
+src_install() {
+ emake -C src DESTDIR="${D}" PREFIX="${EPREFIX}/usr" docdir="${ED%/}/usr/share/doc/${PF}" install
+}