aboutsummaryrefslogtreecommitdiffstats
path: root/app-backup/lifeboat/lifeboat-0.2.0.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-06-04 17:41:10 +0200
committerWynn Wolf Arbor2020-06-04 17:41:10 +0200
commit977bcbf468c6e02e03b1de82d1380dae4a747a9d (patch)
treeda92c2bf328d7410612d3365b55d3985032a1058 /app-backup/lifeboat/lifeboat-0.2.0.ebuild
parent16aa3c0310423de7b6c731c7d0f2f400d7a28b80 (diff)
downloadpramantha-977bcbf468c6e02e03b1de82d1380dae4a747a9d.tar.gz
app-backup/lifeboat: Bump to 0.2.0
Use a snapshot instead of relying on git-r3, add net-misc/rclone as a runtime dependency, and fix the homepage URL. Package-Manager: Portage-2.3.99, Repoman-2.3.22
Diffstat (limited to 'app-backup/lifeboat/lifeboat-0.2.0.ebuild')
-rw-r--r--app-backup/lifeboat/lifeboat-0.2.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-backup/lifeboat/lifeboat-0.2.0.ebuild b/app-backup/lifeboat/lifeboat-0.2.0.ebuild
new file mode 100644
index 0000000..411c1b5
--- /dev/null
+++ b/app-backup/lifeboat/lifeboat-0.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Manage and automate local restic(1) backups"
+HOMEPAGE="https://git.oriole.systems/lifeboat"
+SRC_URI="https://git.oriole.systems/lifeboat/snapshot/${P}.tar.gz"
+
+RESTRICT="mirror"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ acct-group/lifeboat
+ acct-user/lifeboat"
+
+RDEPEND="${DEPEND}
+ app-backup/restic
+ net-misc/rclone"
+BDEPEND=""
+
+src_compile() { :; }
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+}