aboutsummaryrefslogtreecommitdiffstats
path: root/app-backup/lifeboat/lifeboat-0.1.3.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-01-17 12:02:57 +0100
committerWynn Wolf Arbor2020-01-17 12:02:57 +0100
commit2f95f78159ee861710b9f69dd1f45dc2889d6058 (patch)
treece9145e92a731b2bc75dfa21ae9d271f4ef5f330 /app-backup/lifeboat/lifeboat-0.1.3.ebuild
parent4c83d47febfd05f67ff5191d79cac6e4d7369840 (diff)
downloadpramantha-2f95f78159ee861710b9f69dd1f45dc2889d6058.tar.gz
app-backup/lifeboat: Bump to 0.1.3
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Diffstat (limited to 'app-backup/lifeboat/lifeboat-0.1.3.ebuild')
-rw-r--r--app-backup/lifeboat/lifeboat-0.1.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-backup/lifeboat/lifeboat-0.1.3.ebuild b/app-backup/lifeboat/lifeboat-0.1.3.ebuild
new file mode 100644
index 0000000..d09c162
--- /dev/null
+++ b/app-backup/lifeboat/lifeboat-0.1.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3 user
+
+DESCRIPTION="Manage and automate local restic backups"
+HOMEPAGE="https://oriole.systems"
+EGIT_REPO_URI="https://git.oriole.systems/lifeboat.git"
+EGIT_COMMIT="${PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-backup/restic"
+BDEPEND=""
+
+pkg_setup() {
+ enewgroup lifeboat
+ enewuser lifeboat -1 /bin/sh /srv/backup/lifeboat lifeboat
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+}