aboutsummaryrefslogtreecommitdiffstats
path: root/app-backup/lifeboat/lifeboat-0.1.2.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-01-14 15:28:34 +0100
committerWynn Wolf Arbor2020-01-14 15:28:34 +0100
commit33ace6321c9d2453e91252af9e4bc945ac700507 (patch)
tree5084cc954e3873cc7910a715097ffce0521b513d /app-backup/lifeboat/lifeboat-0.1.2.ebuild
parent5ecbe27cfe1e7f93b7b3f2a8bced5cee9ab8e477 (diff)
downloadpramantha-33ace6321c9d2453e91252af9e4bc945ac700507.tar.gz
app-backup/lifeboat: Bump to 0.1.2
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Diffstat (limited to 'app-backup/lifeboat/lifeboat-0.1.2.ebuild')
-rw-r--r--app-backup/lifeboat/lifeboat-0.1.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-backup/lifeboat/lifeboat-0.1.2.ebuild b/app-backup/lifeboat/lifeboat-0.1.2.ebuild
new file mode 100644
index 0000000..d09c162
--- /dev/null
+++ b/app-backup/lifeboat/lifeboat-0.1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3 user
+
+DESCRIPTION="Manage and automate local restic backups"
+HOMEPAGE="https://oriole.systems"
+EGIT_REPO_URI="https://git.oriole.systems/lifeboat.git"
+EGIT_COMMIT="${PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-backup/restic"
+BDEPEND=""
+
+pkg_setup() {
+ enewgroup lifeboat
+ enewuser lifeboat -1 /bin/sh /srv/backup/lifeboat lifeboat
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+}