aboutsummaryrefslogtreecommitdiffstats
path: root/app-admin/kern/kern-0.4.0.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-06-04 16:07:12 +0200
committerWynn Wolf Arbor2020-06-04 16:07:12 +0200
commitb708091887f0f9749b492915fe43475f0b282288 (patch)
tree7485d73bdbba63628d177d6db93ca6be69c198df /app-admin/kern/kern-0.4.0.ebuild
parentf4b915a9ab4fdecbf757c623b5c5576b1129c0f6 (diff)
downloadpramantha-b708091887f0f9749b492915fe43475f0b282288.tar.gz
app-admin/kern: Bump to 0.4.0
Use a regular snapshot instead of cloning the git repository and checking out a specific tag. Fix the homepage URL and drop the neovim dependency. Package-Manager: Portage-2.3.99, Repoman-2.3.22
Diffstat (limited to 'app-admin/kern/kern-0.4.0.ebuild')
-rw-r--r--app-admin/kern/kern-0.4.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-admin/kern/kern-0.4.0.ebuild b/app-admin/kern/kern-0.4.0.ebuild
new file mode 100644
index 0000000..cdda0f9
--- /dev/null
+++ b/app-admin/kern/kern-0.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Configure, build, and install kernels on Gentoo Linux"
+HOMEPAGE="https://git.oriole.systems/kern"
+SRC_URI="https://git.oriole.systems/kern/snapshot/${P}.tar.gz"
+
+RESTRICT="mirror"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-admin/eclean-kernel"
+BDEPEND=""
+
+src_compile() { :; }
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+}