aboutsummaryrefslogtreecommitdiffstats
path: root/app-admin/kern/kern-0.2.0.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-03-23 18:47:29 +0100
committerWynn Wolf Arbor2020-03-23 18:47:29 +0100
commitd130324f0f07bc7b5b30672c566edaa2f141fecb (patch)
tree21fcc8a43231c06b8ff8610402d2c6a5c3845b54 /app-admin/kern/kern-0.2.0.ebuild
parent8ee1011e63c6619692762d03cc053913cf090948 (diff)
downloadpramantha-d130324f0f07bc7b5b30672c566edaa2f141fecb.tar.gz
app-admin/kern: Bump to 0.2.0
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Diffstat (limited to 'app-admin/kern/kern-0.2.0.ebuild')
-rw-r--r--app-admin/kern/kern-0.2.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/kern/kern-0.2.0.ebuild b/app-admin/kern/kern-0.2.0.ebuild
new file mode 100644
index 0000000..b38b895
--- /dev/null
+++ b/app-admin/kern/kern-0.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3
+
+DESCRIPTION="Configure, build, and install kernels"
+HOMEPAGE="https://oriole.systems"
+EGIT_REPO_URI="https://git.oriole.systems/kern.git"
+EGIT_COMMIT="${PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-admin/eclean-kernel
+ app-editors/neovim"
+BDEPEND=""
+
+src_compile() { :; }
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+}