summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWolfgang Müller2019-07-29 19:18:37 +0000
committerWolfgang Müller2019-07-29 19:18:37 +0000
commitc40750e7321a82dca0ca186d6560e90018b34a7d (patch)
treefa25a8034ea690c8eca738f39b16f1a64a3a5b2c
parent0f8de4fa68ab1d2035dc61614c60033fa4f3a378 (diff)
downloadportage-roles-c40750e7321a82dca0ca186d6560e90018b34a7d.tar.gz
group-musl: Add patch that disables utmp/wtmp in openssh
musl only provides stubs for utmp and wtmp functionality, thereby causing annoying log messages from openssh. Whilst this patch has been proposed on the mailing list already, it's not been integrated yet.
-rw-r--r--group-musl/patches/net-misc/openssh/disable-utpm-in-musl.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/group-musl/patches/net-misc/openssh/disable-utpm-in-musl.patch b/group-musl/patches/net-misc/openssh/disable-utpm-in-musl.patch
new file mode 100644
index 0000000..d028988
--- /dev/null
+++ b/group-musl/patches/net-misc/openssh/disable-utpm-in-musl.patch
@@ -0,0 +1,18 @@
+diff --git a/configure.ac b/configure.ac
+index 9022ee9c..f0b40947 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -904,6 +904,13 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
+ else
+ AC_MSG_RESULT([architecture not supported])
+ fi
++ case "$host" in
++ *-*-linux-musl*)
++ AC_DEFINE([DISABLE_UTMP], [1], [Define if you don't want to use utmp])
++ AC_DEFINE([DISABLE_WTMP], [1], [Define if you don't want to use wtmp])
++ ;;
++ esac
++
+ ;;
+ mips-sony-bsd|mips-sony-newsos4)
+ AC_DEFINE([NEED_SETPGRP], [1], [Need setpgrp to acquire controlling tty])