| Commit message (Expand) | Author | Age | Lines |
* | Have _NET_ACTIVE_WINDOW warp the pointer only on direct user input | Wolfgang Müller | 2022-01-23 | -0/+11 |
* | Do not warp mouse to windows marked active by EWMH | Wolfgang Müller | 2022-01-17 | -1/+0 |
* | Fix several sign-compare warnings | Wynn Wolf Arbor | 2021-04-27 | -1/+1 |
* | Add BSD compatibility functions and headers | Wynn Wolf Arbor | 2021-04-27 | -1/+1 |
* | Instead of using _NET_ACTIVE_WINDOW on restart, use the pointer location to d... | okan | 2020-03-26 | -2/+2 |
* | Unrelated style fixes, consistency changes and sorting, appropriate dosage/re... | okan | 2020-03-18 | -10/+10 |
* | Map ('5') and allow mod5mask (altgr) as a modifier. | okan | 2020-03-18 | -2/+2 |
* | Handle _NET_WM_NAME changes. | tim | 2019-04-29 | -2/+3 |
* | Check the atom type on propertynotify before iterating. | okan | 2019-03-11 | -4/+6 |
* | use screen_find() for xrandr crtc changes | okan | 2019-03-10 | -12/+9 |
* | Find the managed screen from the parent window for client_current(). | okan | 2019-03-10 | -5/+9 |
* | Similar to keypress event, fetch the screen from the event root window in the | okan | 2019-03-08 | -7/+5 |
* | extend verbose logging for key/button events | okan | 2019-03-08 | -5/+8 |
* | [keypress event] turns out we've been checking the wrong window for a matching | okan | 2019-03-08 | -7/+8 |
* | add parans for readibility | okan | 2019-03-08 | -5/+5 |
* | Teach client_current() to use a screen to find the current client instead of | okan | 2019-03-07 | -6/+6 |
* | same thing as screen_find() | okan | 2019-03-06 | -8/+4 |
* | Move the group index (desktop number) check to the only 2 callers that require | okan | 2019-02-28 | -3/+7 |
* | Rename internal functions to delinate between client remove, delete and xproto | okan | 2019-02-22 | -4/+4 |
* | Allow 'transientfor' clients to inherit group and bwidth either during init or | okan | 2018-11-13 | -1/+4 |
* | Slightly expand and expose verbose debugging. | okan | 2018-02-04 | -15/+15 |
* | add debugging for x events | okan | 2018-02-02 | -1/+29 |
* | As done for buttonrelease, work specific un-cycling and un-highlighting actions | okan | 2017-12-29 | -2/+13 |
* | Merge group_toggle_membership_leave into the buttonrelease event and only do | okan | 2017-12-29 | -3/+5 |
* | add helper function client_show to bring together like actions for unhide/raise | okan | 2017-12-29 | -5/+2 |
* | Use poll and XNextEvent to replace XNextEvent blocking inside the x11 event | okan | 2017-12-27 | -6/+8 |
* | drop obsolete comment | okan | 2017-05-09 | -2/+1 |
* | Alter callbacks to take a struct instead of a growing number of arguments; | okan | 2017-05-09 | -7/+9 |
* | Refactor callbacks to take a void * so as to not try and generalize into | okan | 2016-10-18 | -20/+32 |
* | Add an argument to the callbacks to pass the xevent context, button or | okan | 2016-10-06 | -3/+3 |
* | When removing xrandr regions, ensure clients are within the bounds of | okan | 2016-10-04 | -1/+2 |
* | client_ptrwarp should not deal with unhiding or raising clients (non ptr | okan | 2016-10-03 | -1/+5 |
* | During init, query screen for _NET_ACTIVE_WINDOW and set that client as | okan | 2016-09-16 | -2/+2 |
* | Fix-up a few simple uses of client_current(): check CLIENT_ACTIVE flag | okan | 2016-09-14 | -4/+7 |
* | Start cleaning up name vs function differences; replace magic numbers. | okan | 2015-11-10 | -3/+3 |
* | Add consistent checks against NULL. | okan | 2015-08-27 | -4/+4 |
* | style | okan | 2015-07-01 | -2/+2 |
* | Re-implement XClientMessage handling so that we can feed screen_find and | okan | 2015-06-30 | -39/+43 |
* | Switch to limits.h; replace MAXPATHLEN and MAXHOSTNAMELEN with PATH_MAX | okan | 2015-01-19 | -2/+3 |
* | these have nothing to do with 'sticky', but rather group membership; rename. | okan | 2014-09-27 | -2/+2 |
* | use similiar style for client flags | okan | 2014-09-15 | -2/+2 |
* | screen_fromroot -> screen_find | okan | 2014-09-07 | -5/+5 |
* | Rework group names: stash the group name inside the group_ctx as opposed | okan | 2014-09-06 | -2/+2 |
* | Move redundant bits from screen_init (while dealing with existing | okan | 2014-02-03 | -2/+2 |
* | Move redundant window attr fetch from maprequest directly into | okan | 2014-02-02 | -7/+4 |
* | Move cwm_status around to avoid header fu, and remove extraneous signal | okan | 2014-01-30 | -2/+1 |
* | Merge keybinding and mousebinding queues into using the same merged | okan | 2014-01-29 | -6/+6 |
* | The EWMH spec states that if the cardinal returned is 0xFFFFFFFF (-1) | okan | 2014-01-28 | -3/+12 |
* | Somewhat streamline event loop/restart/quit handling; most notable | okan | 2014-01-22 | -11/+7 |
* | merge KBFLAG_NEEDCLIENT and MOUSEBIND_CTX_*; brings kbfunc and mousefunc | okan | 2014-01-20 | -4/+4 |