aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml38
1 files changed, 38 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..1142dba
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,38 @@
+[project]
+name = "beancount-oriole"
+version = "0.1.0"
+description = "A collection of beancount plugins"
+requires-python = ">=3.12"
+license = {text = "MIT License"}
+authors = [
+ {name = "Wolfgang Müller", email = "wolf@oriole.systems"}
+]
+classifiers = [
+ "Programming Language :: Python :: 3",
+ "License :: OSI Approved :: MIT License",
+]
+dependencies = [
+ "beancount>=2,<4",
+]
+
+[project.urls]
+Homepage = "https://git.oriole.systems/beancount-oriole/"
+Source = "https://git.oriole.systems/beancount-oriole/"
+
+[build-system]
+requires = ["setuptools >= 61.1"]
+build-backend = "setuptools.build_meta"
+
+[tool.ruff.lint]
+# https://docs.astral.sh/ruff/rules/
+select = [
+ "F", # pyflakes
+ "E", # pycodestyle
+ "W", # pycodestyle
+ "I", # isort
+ "UP", # pyupgrade
+ "A", # flake8-builtins
+ "B", # flake8-bugbear
+ "SIM", # flake8-simplify
+ "FURB" # refurb
+]