aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 23 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..a576a12
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,23 @@
+import setuptools
+
+setuptools.setup(
+ name="ywalk",
+ version="0.1.0",
+ author="Wolfgang Müller",
+ author_email="wolf@oriole.systems",
+ description="A fast-travel companion for The Elder Scrolls III: Morrowind",
+ url="https://git.oriole.systems/ywalk",
+ classifiers = [
+ "Programming Language :: Python :: 3",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: OS Independent",
+ ],
+ packages=setuptools.find_packages(),
+ python_requires=">=3.8",
+
+ entry_points = {
+ 'console_scripts': [
+ 'ywalk = ywalk.main:main',
+ ]
+ }
+)