aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/po/meson.build
diff options
context:
space:
mode:
authorWolfgang Müller2025-02-03 21:00:09 +0100
committerWolfgang Müller2025-02-03 21:00:09 +0100
commit2d51a3b3c8d797bf63672d3ccc74bdd38233cb39 (patch)
tree476cd2f1c43ab66292b83f7100be3211db46f648 /po/meson.build
parentb41adce621c4e6260405303f9b6c2617928c8b6f (diff)
downloadweltschmerz-2d51a3b3c8d797bf63672d3ccc74bdd38233cb39.tar.gz
Don't explicitly pass source directory to gettext
This is not explicitly needed with meson and silences a deprecation warning about meson.source_root(). [1] [1] https://mesonbuild.com/Reference-manual_builtin_meson.html#mesonsource_root
Diffstat (limited to 'po/meson.build')
-rw-r--r--po/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/po/meson.build b/po/meson.build
index 6870f58..8f6f5e7 100644
--- a/po/meson.build
+++ b/po/meson.build
@@ -4,4 +4,4 @@ localedir = join_paths(get_option('prefix'), get_option('localedir'))
add_project_arguments('-DGETTEXT_PACKAGE="weltschmerz"', language: 'c')
add_project_arguments('-DLOCALEDIR="@0@"'.format(localedir), language: 'c')
-i18n.gettext(meson.project_name(), args: '--directory=' + meson.source_root())
+i18n.gettext(meson.project_name())