aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorflorian2014-12-05 20:02:41 +0000
committerWynn Wolf Arbor2020-05-24 12:33:55 +0200
commitd9bf5d00c1f0cc15945ca742f50ea8ae4ae7d764 (patch)
tree6f611ac78e80a9c7db0a1a0d6d6a4f449f1ea5f7
parent9fb6e15abb8df81fedafd3327f726eafd09c8f8f (diff)
downloadslowcgi-d9bf5d00c1f0cc15945ca742f50ea8ae4ae7d764.tar.gz
enable warnings
-rw-r--r--Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index e09a600..f4b7025 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,12 @@
-# $OpenBSD: Makefile,v 1.1 2013/05/23 12:03:24 florian Exp $
+# $OpenBSD: Makefile,v 1.2 2014/12/05 20:02:41 florian Exp $
PROG= slowcgi
SRCS= slowcgi.c
+CFLAGS+= -Wall
+CFLAGS+= -Wstrict-prototypes -Wmissing-prototypes
+CFLAGS+= -Wmissing-declarations
+CFLAGS+= -Wshadow -Wpointer-arith -Wcast-qual
+CFLAGS+= -Wsign-compare
LDADD= -levent
DPADD= ${LIBEVENT}
MAN= slowcgi.8