aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/setup.py
diff options
context:
space:
mode:
authorWolfgang Müller2023-03-30 20:54:27 +0200
committerWolfgang Müller2023-03-30 20:59:10 +0200
commit1c2e7e52e388bdb64bbb2190047e014ff33f973b (patch)
tree07b52a1d297750c70a10ebe0c1e2dc9d941f32af /setup.py
parentf10377961aaf9294316569d3ec198a5a7ce093ab (diff)
downloadquarg-1c2e7e52e388bdb64bbb2190047e014ff33f973b.tar.gz
Migrate to poetry
We have used this in another project of ours and prefer its interface over pip's and its toml configuration over setup.py. There should be no functional change.
Diffstat (limited to '')
-rw-r--r--setup.py28
1 files changed, 0 insertions, 28 deletions
diff --git a/setup.py b/setup.py
deleted file mode 100644
index 0fc68f6..0000000
--- a/setup.py
+++ /dev/null
@@ -1,28 +0,0 @@
-import setuptools
-
-setuptools.setup(
- name="quarg",
- version="0.1.3",
- author="Wolfgang Müller",
- author_email="wolf@oriole.systems",
- description="Search Quassel logs for matching messages and print them",
- url="https://git.oriole.systems/quarg",
- classifiers = [
- "Programming Language :: Python :: 3",
- "License :: OSI Approved :: MIT License",
- "Operating System :: OS Independent",
- ],
- packages=setuptools.find_packages(),
- python_requires=">=3.8",
-
- entry_points = {
- 'console_scripts': [
- 'quarg = quarg.main:main',
- ]
- },
-
- install_requires=[
- 'python-dateutil>=2.8.1',
- 'sqlalchemy>=1.4',
- ],
-)