aboutsummaryrefslogtreecommitdiffstats
path: root/net-irc/quarg/quarg-0.1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--net-irc/quarg/quarg-0.2.0.ebuild (renamed from net-irc/quarg/quarg-0.1.3.ebuild)6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-irc/quarg/quarg-0.1.3.ebuild b/net-irc/quarg/quarg-0.2.0.ebuild
index d2de9a1..0657929 100644
--- a/net-irc/quarg/quarg-0.1.3.ebuild
+++ b/net-irc/quarg/quarg-0.2.0.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{10,11} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_USE_PEP517=poetry
inherit distutils-r1
DESCRIPTION="Search Quassel logs for matching messages and print them"
@@ -21,8 +21,8 @@ IUSE="sqlite postgres"
RDEPEND="${PYTHON_DEPS}
dev-python/python-dateutil[${PYTHON_USEDEP}]
- postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
- >=dev-python/sqlalchemy-1.4[${PYTHON_USEDEP},sqlite?]
+ postgres? ( dev-python/psycopg[${PYTHON_USEDEP}] )
+ >=dev-python/sqlalchemy-2.0[${PYTHON_USEDEP},sqlite?]
"
DEPEND="${RDEPEND}"