aboutsummaryrefslogtreecommitdiffstats
path: root/dev-python/autobean-refactor/autobean-refactor-0.2.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/autobean-refactor/autobean-refactor-0.2.5.ebuild')
-rw-r--r--dev-python/autobean-refactor/autobean-refactor-0.2.5.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/autobean-refactor/autobean-refactor-0.2.5.ebuild b/dev-python/autobean-refactor/autobean-refactor-0.2.5.ebuild
new file mode 100644
index 0000000..2ffc396
--- /dev/null
+++ b/dev-python/autobean-refactor/autobean-refactor-0.2.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYPI_NO_NORMALIZE=yes
+PYTHON_COMPAT=( python3_{12,13} )
+DISTUTILS_USE_PEP517=pdm-backend
+inherit distutils-r1 pypi
+
+DESCRIPTION="An ergonomic and losess beancount manipulation library"
+HOMEPAGE="https://github.com/SEIAROTg/autobean-refactor https://pypi.org/project/autobean-refactor/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-python/lark-1.1.5[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.4.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"