aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/fava/fava-1.21.ebuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--app-office/fava/fava-1.21.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/app-office/fava/fava-1.21.ebuild b/app-office/fava/fava-1.21.ebuild
index d292092..6ebe352 100644
--- a/app-office/fava/fava-1.21.ebuild
+++ b/app-office/fava/fava-1.21.ebuild
@@ -1,10 +1,12 @@
# Copyright 2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_9 )
-inherit distutils-r1 elisp-common
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1
DESCRIPTION="Web interface for the accounting tool Beancount"
HOMEPAGE="https://beancount.github.io/fava/ https://pypi.org/project/fava/"
@@ -30,8 +32,6 @@ RDEPEND="
"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-
python_test() {
# test_static_url presumes and requires the existence of these two files.
# They need only to exist in order for the code to determine the mtime