aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/fava/fava-1.14-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--app-office/fava/fava-1.14-r2.ebuild (renamed from app-office/fava/fava-1.14-r1.ebuild)13
1 files changed, 12 insertions, 1 deletions
diff --git a/app-office/fava/fava-1.14-r1.ebuild b/app-office/fava/fava-1.14-r2.ebuild
index f4cf01b..9bd08ad 100644
--- a/app-office/fava/fava-1.14-r1.ebuild
+++ b/app-office/fava/fava-1.14-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_7 )
DISTUTILS_USE_SETUPTOOLS="rdepend"
inherit distutils-r1 elisp-common
@@ -30,3 +30,14 @@ RDEPEND="
dev-python/jaraco-functools[${PYTHON_USEDEP}]
"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ # test_static_url presumes and requires the existence of these two files.
+ # They need only to exist in order for the code to determine the mtime
+ # value.
+ mkdir -p fava/static/{javascript,css} || die
+ touch fava/static/javascript/main.ts || die
+ touch fava/static/css/style.css || die
+
+ py.test -v || die
+}