aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/fava-plugins/fava-plugins-1.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/fava-plugins/fava-plugins-1.0-r1.ebuild')
-rw-r--r--app-office/fava-plugins/fava-plugins-1.0-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/app-office/fava-plugins/fava-plugins-1.0-r1.ebuild b/app-office/fava-plugins/fava-plugins-1.0-r1.ebuild
new file mode 100644
index 0000000..3f5b022
--- /dev/null
+++ b/app-office/fava-plugins/fava-plugins-1.0-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{10,11} )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_SINGLE_IMPL=1
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A collection of beancount plugins"
+HOMEPAGE="https://pypi.org/project/fava-plugins/ https://github.com/beancount/fava-plugins"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=app-office/beancount-2.0[${PYTHON_SINGLE_USEDEP}]"