aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/autobean-format/autobean-format-0.1.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--app-office/autobean-format/autobean-format-0.1.6.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-office/autobean-format/autobean-format-0.1.6.ebuild b/app-office/autobean-format/autobean-format-0.1.6.ebuild
new file mode 100644
index 0000000..b2ecd42
--- /dev/null
+++ b/app-office/autobean-format/autobean-format-0.1.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYPI_NO_NORMALIZE=yes
+PYTHON_COMPAT=( python3_{12,13} )
+DISTUTILS_USE_PEP517=pdm-backend
+inherit distutils-r1 pypi
+
+DESCRIPTION="Yet another formatter for beancount"
+HOMEPAGE="https://github.com/SEIAROTg/autobean-format https://pypi.org/project/autobean-format/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-python/autobean-refactor-0.2.3[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.4.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"