aboutsummaryrefslogtreecommitdiffstats
path: root/app-backup/lifeboat/lifeboat-0.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--app-backup/lifeboat/lifeboat-0.3.0.ebuild (renamed from app-backup/lifeboat/lifeboat-0.2.1.ebuild)6
1 files changed, 5 insertions, 1 deletions
diff --git a/app-backup/lifeboat/lifeboat-0.2.1.ebuild b/app-backup/lifeboat/lifeboat-0.3.0.ebuild
index 411c1b5..6fa2923 100644
--- a/app-backup/lifeboat/lifeboat-0.2.1.ebuild
+++ b/app-backup/lifeboat/lifeboat-0.3.0.ebuild
@@ -1,8 +1,10 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit systemd
+
DESCRIPTION="Manage and automate local restic(1) backups"
HOMEPAGE="https://git.oriole.systems/lifeboat"
SRC_URI="https://git.oriole.systems/lifeboat/snapshot/${P}.tar.gz"
@@ -27,4 +29,6 @@ src_compile() { :; }
src_install() {
emake PREFIX=/usr DESTDIR="${D}" install
+
+ systemd_dounit etc/systemd/${PN}@.{service,timer}
}