aboutsummaryrefslogtreecommitdiffstats
path: root/www-misc/slowcgi/slowcgi-7.3.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2023-10-12 12:15:24 +0200
committerWolfgang Müller2023-10-12 12:15:24 +0200
commitffb946f4f93559e06a8673f412377d268d32ae73 (patch)
tree15998b5a99c3577f553bf27b339435fb046e377c /www-misc/slowcgi/slowcgi-7.3.ebuild
parenta79172cb3bfd4122f3389a8f3d60e063d4a36218 (diff)
downloadpramantha-ffb946f4f93559e06a8673f412377d268d32ae73.tar.gz
www-misc/slowcgi: add 7.3
Diffstat (limited to '')
-rw-r--r--www-misc/slowcgi/slowcgi-7.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/www-misc/slowcgi/slowcgi-7.3.ebuild b/www-misc/slowcgi/slowcgi-7.3.ebuild
new file mode 100644
index 0000000..8ed5723
--- /dev/null
+++ b/www-misc/slowcgi/slowcgi-7.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="a FastCGI to CGI wrapper server"
+HOMEPAGE="https://git.oriole.systems/slowcgi"
+SRC_URI="https://git.oriole.systems/slowcgi/snapshot/${P}.tar.gz"
+
+RESTRICT="mirror"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ acct-user/slowcgi
+ acct-group/http"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-Add-flag-to-run-in-the-foreground.patch"
+)
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+
+ newinitd "${FILESDIR}"/slowcgi.initd slowcgi
+ newconfd "${FILESDIR}"/slowcgi.confd slowcgi
+}