aboutsummaryrefslogtreecommitdiffstats
path: root/www-misc/slowcgi/slowcgi-6.9.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2021-05-27 15:32:11 +0200
committerWolfgang Müller2021-05-27 15:32:11 +0200
commit1588384c6b6f0a00b99e8a89d3c877e4a47c4878 (patch)
tree91d424c1f7729705cb6ed0b710ec2a33e771537f /www-misc/slowcgi/slowcgi-6.9.ebuild
parenta4c6c8621fe0c090fa0e45d70bb2ece8a29b070f (diff)
downloadpramantha-1588384c6b6f0a00b99e8a89d3c877e4a47c4878.tar.gz
www-misc/slowcgi: Add 6.9
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Wolfgang Müller <wolf@oriole.systems>
Diffstat (limited to '')
-rw-r--r--www-misc/slowcgi/slowcgi-6.9.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/www-misc/slowcgi/slowcgi-6.9.ebuild b/www-misc/slowcgi/slowcgi-6.9.ebuild
new file mode 100644
index 0000000..8ed5723
--- /dev/null
+++ b/www-misc/slowcgi/slowcgi-6.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="a FastCGI to CGI wrapper server"
+HOMEPAGE="https://git.oriole.systems/slowcgi"
+SRC_URI="https://git.oriole.systems/slowcgi/snapshot/${P}.tar.gz"
+
+RESTRICT="mirror"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ acct-user/slowcgi
+ acct-group/http"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-Add-flag-to-run-in-the-foreground.patch"
+)
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+
+ newinitd "${FILESDIR}"/slowcgi.initd slowcgi
+ newconfd "${FILESDIR}"/slowcgi.confd slowcgi
+}