aboutsummaryrefslogtreecommitdiffstats
path: root/www-misc/skein/skein-0.0.1.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-05-27 16:32:03 +0200
committerWynn Wolf Arbor2020-05-27 16:32:35 +0200
commitc051189e4693eafc6346812328a1886d85c23fa2 (patch)
tree4200562cf589dcee59c5fecbf3c6e9190918cb8c /www-misc/skein/skein-0.0.1.ebuild
parent47b32277ea62174adeb56dac958942b61c7139b9 (diff)
downloadpramantha-c051189e4693eafc6346812328a1886d85c23fa2.tar.gz
www-misc/skein: Add 0.0.1
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Diffstat (limited to '')
-rw-r--r--www-misc/skein/skein-0.0.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/www-misc/skein/skein-0.0.1.ebuild b/www-misc/skein/skein-0.0.1.ebuild
new file mode 100644
index 0000000..e696307
--- /dev/null
+++ b/www-misc/skein/skein-0.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3
+
+DESCRIPTION="secure cgit hosting with slowcgi(8)"
+HOMEPAGE="https://git.oriole.systems/skein.git"
+EGIT_REPO_URI="https://git.oriole.systems/skein.git"
+EGIT_COMMIT="${PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ www-misc/slowcgi
+ >=www-apps/cgit-1.2.3-r3[static]
+"
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+
+ newinitd "${FILESDIR}"/cgit-chroot.initd cgit-chroot
+}